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Introduction Welcome

Introduction

Welcome
SerialXpress is a tool for the high speed serial data industry that takes an input pattern and creates
pre-distorted waveforms to test a device’s conformance to SATA, HDMI, Display Port, PCI Express, SAS,
and Fiber channel standards.

Free Trial
SerialXpress supports Option SSC and Option ISI that enables SSC parameters and ISI options
respectively. You can transfer or save the data for ten trials. When the trial expires, you cannot transfer or
save the waveform unless you enable the function with an option (license) key.

For more details, refer to Option Installation.

Related Documentation
In addition to this SerialXpress Online Help, the following documentation is included with the software:

SerialXpress Installation Manual (Tektronix part number 077-0049-XX). The installation manual has
information about installing and upgrading the software.

SerialXpress User Manual (Tektronix part number 077-0050-XX). The user manual is adapted from
the online help and is available in PDF format.

SerialXpress Quick Start User Manual (Tektronix part number 077-0064-XX). The quick start user
manual has information about using the software and application examples.

Conventions
The online help uses the following conventions:

When steps require a sequence of selections using the software interface, the ">" delimiter marks each
transition between a menu and an option. For example, File > Save.

DUT refers to the Device Under Test.

Three dots (...) following a menu item indicates that the menu item will open a submenu or a dialog box.

The terms "waveform" and "waveform" are used interchangeably.

The term AWG refers to a Tektronix Arbitrary Waveform Generator (AWG5000/AWG7000).
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Introduction Feedback

Feedback
Tektronix, Inc.

14200 SW Karl Braun Drive

P.O. Box 500

Beaverton, OR 97077

USA

For product information, sales, service, and technical support:

In North America, call 1-800-833-9200.

Worldwide, visit www.tektronix.com to find contacts in your area.
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Getting Started Minimum System Requirements

Getting Started

Minimum System Requirements
The minimum requirements of the SerialXpress application are listed in the following table:

Table 1: Minimum system requirements
OS Supported Minimum Requirements
Processor Intel Celeron processor
Windows XP Professional and Windows Vista 2.0 GHz or higher

1 GB RAMService Pack 2.0
2 GB free disk space

xxx

Ordering SerialXpress
SerialXpress can be ordered as follows:

Table 2: Ordering SerialXpress
Software packages and options Description
SDX100 Jitter generation software package for AWG5000/AWG7000

(includes option key).
Option ISI S-Parameter and ISI creation option (requires SDX100 as

prerequisite).
Option SSC Spread Spectrum Clock addition option (requires SDX100

as prerequisite).
SDXUP Base Software upgrade for SDX100.
Option ISI Upgrade to include S-Parameter and ISI creation option

for SDX100.
Option SSC Upgrade to include Spread Spectrum Clock option for

SDX100.
xxx
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Getting Started Installation

Installation
An installation wizard installs SerialXpress. If you have not installed MATLAB Runtime version 7.6,
TekVISA version 3.3.0.14, and .NET 2.0, you will be notified during installation. You can cancel the
installation any time during the process.

NOTE. You can download the TekVISA software from www.tektronix.com/software. You can also install
TekVISA from the path \TekVISA on the application CD.

For details on how to install the application, refer to the SerialXpress Installation Manual (Tektronix part
number 077-0049-XX) available as a PDF on the CD-ROM.

You can uninstall in either of these two ways:

From Start > All Programs > Tektronix SerialXpress > Uninstall SerialXpress.

From Add/Remove programs in Control panel.
Connection Setups

Setup for Base Data Signal Generation
1. Start the SerialXpress installed on the Arbitrary Waveform Generator (AWG).

2. Select the Standard and Pattern type from the Base Pattern tab.

3. Make connections as shown in the following figure:

Connect the AWG Ch 1 Analog Output to the DUT where the base data waveform must be fed.

When using the Interleave mode, the output should be taken from Interleave output as shown.

4. Click Compile in the toolbar. The waveform is compiled according to the default settings in the
Compile Settings dialog box. The compiled waveform is displayed in the Waveform List. This
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waveform will be transferred to the AWG channel (Ch1) and can also be seen in the Instrument
Control > AWG tab.

5. Click On/Off to turn on Ch1.

6. Click Run to generate the waveform on the AWG.

For more details, refer to Calibration for Base Pattern Signals and Find Instruments.

Calibration Setup for RT-Eye Serial Compliance and Analysis
Perform the following steps to set the RT-Eye Serial Compliance and Analysis application for jitter
analysis:

1. On the menu bar, click App > RT-Eye Serial Compliance and Analysis to start the RT-Eye Serial
Compliance and Analysis application.

The oscilloscope display resizes to fit in the upper part of the screen. The lower part of the oscilloscope
screen displays the RT-Eye Serial Compliance and Analysis application.

2. Perform the following steps for jitter analysis:

a. SelectModules > Serial Analysis and set the probe type as Differential. Select Jitter@BER
and TIE Jitter in the Jitter group.
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b. SelectMeasurements > Configure > Source and set Differential source to Ch1.

c. In the Ref Levels tab, set Autoset to Run.

d. In the Clock Recovery tab, setMethod to Const Clk: Mean. Adjust the bit rate to match the data
rate value set in the Calibration Setup dialog box in the SerialXpress application.
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e. In the Jitter tab, set the Type to Repeating. Also, set the Pattern to Custom and Length to 2 UI.

3. SelectMath > Math Setup on the oscilloscope menu bar and set the value ofMath1 to Ch1– Ch3.

Ensure that the horizontal scale and the record length are set appropriately. For example, in a
TDS6154C oscilloscope, the horizontal scale can be set to 20 μs/div and the record length to 4M.
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Operating Basics

About Basic Operations
The basic operations section describes the application, tells how to start the application, use the menus and
toolbars, and describes the dialog boxes.

In this online help, all menu selections are indicated with Menu name and Menu options separated by
">". You can access a command or a menu option in more than one way. Several main menu options are
available in a toolbar that you can use instead of selecting the option from the main menu. Shortcut menus,
which open with a right-click, are provided for renaming, deleting waveforms, showing graphs, saving
data, importing data from a Tektronix oscilloscope, and transferring a waveform to an AWG.

Some dialog boxes also have a Help button that displays help for that dialog box.

Detailed operations and parameters are described in the sections on Base Pattern, Transmitter, and
Channel/Cable. The Reference section lists Error Messages, Shortcut Keys, Default states/values, Table
of Measurements, and additional information on Calibration, Interleave, Noise, Pseudo Random Binary
Sequence (PRBS), Spread Spectrum Clocking (SSC), and Inter Symbol Interference (ISI).

The following figure shows the SerialXpress screen, the menu, the toolbar, and other elements of the
user interface.
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Overview of the Software
SerialXpress is a tool for the high speed serial data industry that takes an input pattern and creates
pre-distorted waveforms to test a device’s conformance to SATA, SAS, HDMI, Display Port, Fiber
Channel, and PCI-Express standards.

Key Features
Jitter Generation: Up to four different sinusoidal jitters with different amplitudes, frequencies and
phases can be added to a base pattern. Two independent band-limited random jitters can also be
added to the base pattern.

SSC Addition: SSC can be added with precisely controlled profile, spread, deviation, modulation,
df/dt, and noise.

Pre/De-emphasis and Noise: Many standards such as PCI-E require the output waveform to be
pre/de-emphasized. SerialXpress allows easy addition of pre/de-emphasis with all other jitter
parameters. Vertical noise can be added at both near and far ends of the channel.

Inter Symbol Interference (ISI) Creation: SerialXpress allows you to create ISI either by entering it
directly or from an S-parameter file captured either from a Tektronix sampling oscilloscope or a Vector
Network Analyzer. The S-parameter can be directly convolved with the base pattern to recreate the
channel characteristics. By applying an inverse filter, the effects of the channel can be de-embedded
from the circuit. The ISI within the S-parameter can be scaled upward or downward easily altering the
characteristics of the channel.

Base Pattern: SerialXpress is bundled with several sample patterns for various standards like SATA,
Display Port, SAS, PCI-E, HDMI, and Fiber Channel. Patterns can also be directly entered in a Binary
or Hex editor, or loaded from a file.

Idle State: Standards like SATA call for OOB signaling which requires an idle state followed by a
burst. You can directly create this idle state without using additional power dividers. Noise can also be
added to these idle state waveforms.

Calibration: SerialXpress has a built-in calibration routine, which controls a Tektronix oscilloscope
and calibrates the output of a Tektronix arbitrary waveform generator (AWG) for periodic jitter,
random jitter, and rise time.

Bandwidth Expansion Filter: The rise time of an AWG can be expanded further by applying the
bandwidth expansion filter. For example, when used with an AWG7012 with option 06, the bandwidth
enhancement filter compensates for the DAC roll-off at higher frequencies, thereby extending the
bandwidth up to 9 GHz.

Batch Processing: When more than one pattern needs to be synthesized, you can use batch processing
to create multiple waveforms with a combination of random and sinusoidal jitter with a maximum
of four different frequencies.

Overview Window: All jitter parameters can be switched on or switched off from the overview window.
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Starting the Software
From the Start menu, click All Programs > Tektronix SerialXpress > SerialXpress. You can also
double-click the SerialXpress shortcut on the desktop.

You can use the application in three modes:

When SerialXpress is started with the AWG5000/AWG7000 software running, it is called online
mode. In this case, the SerialXpress automatically detects the AWG software. You can transfer data
directly to the AWG software.

When SerialXpress is started without the AWG5000/AWG7000 software running, it is called offline
mode. You can transfer data to the AWG offline software.

When SerialXpress is started on the PC without the AWG5000/AWG7000 software running,
SerialXpress does not detect the AWG software. In this case, you cannot transfer data to the AWG
(although you can create and store the waveform for later use).

NOTE. The AWG5000/AWG7000 software refers to the AWG5000/AWG7000 memory manager and
AWG5000/AWG7000 Virtual GPIB parser executables. The AWG5000/AWG7000 user interface
application and other executables are not necessary but they may also be running.

Exiting the Software
Select File > Exit to exit the application. If you have not saved the waveforms, you are prompted to
do so. This option is always enabled.
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File Name Extensions and Directories
The application uses the following file name extensions:

Table 3: File name extensions and their descriptions
File name extension Description
.csv Ascii file containing Comma Separated Values. This file

format may be read by any ascii text editor (such as
Notepad) or may be imported into spreadsheets such as
Excel.

.sxs XML (Extensible Markup Language) file containing setup
information or creating a waveform.

.wfm Binary file containing an oscilloscope waveform record in a
recallable, proprietary format.

.sxc Custom format binary file containing the calibration related
information.

.s1p

.s2p

.s4p

Files that define 1-port, 2-port, and 4-port S-Parameters.

xxx

The application uses the following directories:

Table 4: Directory names and their descriptions
Directory Description
<Application installation path>\Tek-

tronix\SerialXpress\System
Contains the software executables, DLL files, sample
patterns, and touchstone files.

<Application installation path>\Tek-

tronix\SerialXpress\Documentation
Contains the related documentation as text and PDF files.

<Application installation path>\Tek-

tronix\SerialXpress\Samples
Contains sample waveform files.

<Application installation path>\Tek-

tronix\SerialXpress\Samples\SATA
Contains sample base data files for patterns such as MFTP,
HFTP, and others in .txt format.

<Application installation path>\Tek-

tronix\SerialXpress\Samples\SAS
Contains sample base data files for patterns such as JTPAT
+ve disparity, JTPAT -ve disparity, and others in .txt

format.
<Application installation path>\Tek-

tronix\SerialXpress\Samples\HDMI
Contains sample base data files for patterns such as 480p 8
59 Gray RGB, 720p 8 60 Gray RGB, and others in .txt

format.
<Application installation path>\Tek-

tronix\SerialXpress\Samples\DisplayPort
Contains sample base data files for patterns such as DP
Training sequence2 960, CJTPAT, and others in .txt

format.
<Application installation path>\Tek-

tronix\SerialXpress\Samples\PCI-Express
Contains sample base data files for patterns such as
Compliance Pat in .txt format.
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Table 4: Directory names and their descriptions (cont.)

Directory Description
<Application installation path>\Tek-

tronix\SerialXpress\Samples\Fiber

Channel

Contains sample base data files for patterns such as
CJTPAT, JTPAT, and others in .txt format.

<Application installation path>\Tek-

tronix\SerialXpress\Samples\General
Contains sample base data files for patterns such as Clock,
PRBS7, and others in .txt format.

<Application installation path>\Tek-

tronix\SerialXpress\Samples\PRBS
Contains sample PRBS patterns such as PRBS7, PRBS9,
and others in .txt format.

<Application installation path>\Tek-

tronix\SerialXpress\Samples\Clock
Contains sample clock pattern files in .txt format.

<Application installation path>\Tek-

tronix\SerialXpress\Samples\User

Defined

This folder is empty. You can store the sample files that
you define in this folder.

<Application installation path>\Tek-

tronix\SerialXpress\Samples\Touchstone
Contains sample touchstone files used with the S-Parameter
Filter.

xxx
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Menus and Toolbars

Menu Bar
The SerialXpress menu has the following items:

File

Use the File menu to:

Restore the default setup for the currect active parameters.

Open a saved setup. The supported file is in .sxs format.

Save a setup in the .sxs format.

Save a setup under another name in the .sxs format.

Import from file. The supported file is in .DTG (Data Timing Generator) format.

Import data from a Tektronix oscilloscope.

Save data in .wfm format.

Exit the application.
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View

Use the View menu to:

View or hide the toolbar. If the toolbar is hidden before closing the application, it remains
hidden when the application is opened again.

View or hide the status bar. If the status bar is hidden before closing the application, it remains
hidden when the application is opened again.

Configure

Use the Configure menu to:

Find instruments that are connected on the network.

Waveform

Use the Waveform menu to:

Compile a new waveform file based on current settings.

Open the Compile Settings dialog box and define the compile options.

Open the Graph Setup dialog box and define the graph setup.
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System

Use the System menu to:

Set the AWG run mode to on.

Set the AWG run mode to off.

Turn all the channel outputs to on or off on the AWG.

Open the Calibration dialog box and set the parameters to calibrate the waveform.

Open the Option Installation dialog box and enable the function with an option (license) key.

NOTE. All these menu items except Option Installation... are enabled when SerialXpress is running
in the online mode.

Window

View or hide the waveform list.

View or hide the graph window.

View or hide the instrument control window.

Open the Overview window.

Close all windows.
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Help

Use the Help menu to:

Open the online help.

Display technical support contact information on the Tektronix Web site.

Display information about the application, such as version number.

Standard Toolbar
Select View > Standard toolbar to hide or show the toolbar. The toolbar is always displayed by default.

The Standard toolbar has the following options that you can select:

Calibration

Overview

Find Instruments

Graph Setup

Compile

Compile Settings

Batch Setup

On/Off

Run
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Status Bar
Select View > Status Bar to hide or show the status bar. The status bar shows the selected application
and the AWG mode. The status bar is always displayed by default.

When SerialXpress is running on the PC without AWG software, the status bar shows "AWG Not
Available".

When SerialXpress is running with AWG software in the online mode, the status bar shows
"Mode : Online Model: xxxxx", where “xxxxx” is the instrument model number.

When SerialXpress is running with AWG software in the offline mode, the status bar shows
"Mode : Offline".

When Batch Process is enabled in the Compile Settings dialog box, the status bar shows "Batch Compile
Selected". When Batch Process is disabled, the status bar does not show a message.

Waveform List
SelectWindow > Waveform List to view the waveform list. Waveform list is a floating window that
displays a list of all the waveforms. It can be moved anywhere in the display area. By default it is always
displayed and opens in the leftmost area of the display window.

After you select a pattern to generate and set the parameters for it, you must compile it to create the data.
Once you compile a waveform (using Compile from the toolbar), waveform data is created and added to
the waveform list. The Waveform list displays the Name, Length, Sampling Rate, and Time and Date
of the waveform data.

To save a waveform that is available in the list, select the waveform and select File > Save Data As....
The compiled waveform is saved as a data file (.wfm) in the specified location. If there is no data to
save, then the Save Data As... option is disabled.

NOTE. If you close the application without saving the compiled waveform, the waveform is lost. You can
compile the waveform again from the setup, if you have saved the setup using File > Save Setup or
Save Setup As....
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You can select the following options from the shortcut menu:

Table 5: Shortcut menu options and their description
Selection Description
Send to AWG Enabled only if the SerialXpress is running with AWG

software in the online mode and when a waveform is
selected. Sends the selected waveform data to a Tektronix
AWG. Select the channel to which to send the data. The
number of channels and their state in the list depends on
the model of AWG and its current settings.

Show Graph Enabled only when a waveform is selected. You can select
Simulated Data Signal, Normal Eye, and Eye DPO graphs
from this option.

Save Data As... Enabled only when a waveform is selected. Saves the
selected waveform data as a .wfm file under the specified
name and location.

Import from Tektronix Oscilloscope... Imports data from a Tektronix oscilloscope that is connected
to the instrument or PC on which the application is running.

Delete All Enabled only when one or more waveforms are available in
the Waveform List. Deletes all the waveforms shown in the
waveform list permanently.

Delete Enabled only when a waveform is selected. Deletes the
selected waveform permanently.

Rename... Enabled only when a waveform is selected. Opens a dialog
box that allows you to enter a waveform name. When
a waveform name already exists, an error message is
displayed.

NOTE. All the properties of the waveform remain
the same except the waveform name.

xxx

You can select multiple contiguous and non-contiguous waveforms using the Shift and Ctrl keys,
respectively. When you select multiple waveforms in the waveform list, the Show Graph, Save Data
As..., and Rename... options are disabled. Selecting multiple waveforms and the Delete option deletes
all the selected waveforms.
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Toolbar Options and Dialog Boxes

Calibration
Click System > Calibration... or Calibration in the toolbar to calibrate the waveform. This option is
enabled when SerialXpress is running in the online mode. You can calibrate the parameters like random
jitter, rise time, and fall time.

NOTE. Update the TekVisa resource manager before performing calibration. Only TDS6000C, DPO70000,
and DSO70000 series oscilloscopes are listed.

MFTP is used as input data for jitter calibration and clock waveform is used for rise/fall time calibration.

You can save the calibration data as an .sxc file.

This dialog box is displayed upon clicking Calibration. The calibration settings are as follows:

The table displays a list of instruments on the network. The instrument model, status, connection type, and
name are shown but they are not editable. The following buttons are available:

Table 6: Instrument setup buttons and their description
Button Description
Connect Connects to the instrument selected in the table and

updates the status to Connected in the table.
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Table 6: Instrument setup buttons and their description (cont.)

Button Description
Disconnect Disconnects the instrument selected in the table and

updates the status in the table.
Test Connection Returns the current status of the selected instrument in the

table and displays the status as Connected (in green) or
Not Connected (in red).

xxx

The Calibration Settings are as follows. All the calibration settings that are set in SerialXpress are updated
on the connected instrument.

Table 7: Instrument setup options and their description
Selection Description
Calibration Setup
Sample rate (S/s) Displays the sampling rate of the instrument. If you change

the sampling rate, it is also updated in the instrument.
Data rate (S/s) Displays the data rate of the instrument.
Interleave Available when the sampling rate is greater than or equal to

10 GS/s.
Zeroing Enabled only when Interleave is available on the instrument.
File Specify the file to create. The file that you specify will be

used when you compile the waveform.
xxx

The status of calibration process is shown at the bottom of Calibration dialog box.

Click Calibrate to start the calibration process. The following message is displayed.

Click Continue to proceed with the calibration process. The following message is displayed.
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For initial setup of RT-Eye Serial Compliance and Analysis application, refer to Calibration Setup for
RTEye Serial Compliance and Analysis. Once the initial setup is complete, click Continue to proceed
with the calibration process.

At the end of the process, save the calibration data in a file specified in the file path. You can use Browse to
select a previously saved calibration file. Click Apply for the changes to take effect without recalibrating.

NOTE. Interleave and Zeroing are available only on the AWG7000 series of instruments with Option 06.
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Overview
ClickWindow > Overview to view the overview window. A block view of the active waveform settings
appears in a new window. This window is a floating window and can be moved around the screen. Each
larger grouping in the diagram corresponds to a tab. This option is always enabled.

The Overview window has the following blocks:

The On/Off button in the right side of each block corresponds to the check box for the group on the settings
tab. When the button is Off, the previous settings are retained but not used for Compile operation.

If the group does not have a check box, then On/Off button are not displayed on the block.

If the check box is disabled, the button text is Off (red).

If the check box is enabled, the button is On (green). The button on the block and the check box in the
group box are linked—if you change one, the change is reflected in the other.

For Periodic Jitter, if any of the periodic jitter parameters are selected in the Base Pattern tab, then the
corresponding button is On in the Overview dialog box.

When you click any block in the Overview dialog box, the corresponding parameter is highlighted in the
application and the Overview dialog box closes.
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Find Instruments
Click Configure > Find Instruments... to view the find instruments window. You can find instruments
on the network and connect to them. This option is always enabled.

Table 8: Find instruments options and their description
Button Description
Connect Connect to the instrument selected in the table. Connect

is enabled by default if an instrument is highlighted in the
table; disabled if no instrument is highlighted.

Disconnect Disconnect the connected instrument. Enabled only if
highlighted instrument is connected.

Refresh Refresh the list of instruments.
Import... Open the Import from Tektronix Oscilloscope dialog box to

select a file to import.
xxx

Click Connect to connect to the selected instrument. The Status provides the current status during the
refresh operation: Searching Instruments or Ready.

Graph Setup
ClickWaveform > Graph Setup... to view the graph setup window. This option is always enabled.

Graphs are created and updated as part of the Compile operation. You can display any two plots at a time.
The plots cannot be edited or saved. If you change any of the parameter values, you must compile again to
display the changes in the plot. You can maximize one plot at a time and zoom a selected area of interest.

The application allows you to select the types of graphs before creating them. The graphs are displayed as
a set in a small window (for preview). At any time, a maximum of two graphs can be displayed in the
small view.

To specify the graphs to create, click Graph Setup in the toolbar orWaveform > Graph Setup from
the menu bar. The Graph Setup dialog box opens.
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Follow these steps to select the graphs to create:

Highlight a graph from Available Graphs. Click Add to add the graph to the Selected Graphs area or
drag and drop the graph to the Selected Graphs area.

You can select the plots to display. SerialXpress supports the following plots:

Rise/Fall

Simulated Data Signal

Random Jitter

Periodic Jitter

Total Jitter

Normal Eye

Eye DPO

TIE

NOTE. By default, Simulated Data Signal and Eye DPO are selected. Once two graphs are added to
Selected Graphs, the application will not allow you to add any more graphs. You must remove a graph
before you can add another graph.
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To remove a graph, highlight a graph in Selected Graphs and click Remove in the Graph Setup
dialog box or Delete on the keyboard.

Click OK to view the graphs. The graphs are displayed in the Graph tab.

Compile
ClickWaveform > Compile to compile a currently active waveform.

The waveform is compiled and displayed in the Waveform List. You can save the waveform data as a .wfm
file using the Waveform List shortcut menu. This option is not enabled when compilation is in progress.

Compile Settings
ClickWaveform > Compile Settings... to specify compilation settings for the currently active waveform
setup. This option is always enabled. This dialog box is displayed.
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Table 9: Compile settings options and their description
Selection Description
Waveform Name Enter the waveform name.

The waveform name is same as the pattern selected, except
for patterns such as User Defined. You can change the
waveform name either in the Compile Settings dialog box
or by using Rename option from the waveform list shortcut
menu.

Automatic Enable this to calculate the sampling rate. By default, this
is enabled. When disabled, you can change the sampling
rate or samples per UI.
In the offline mode, the sampling rate of the waveform is
20 GS/s. In the online mode, the sampling rate of the
waveform depends on the maximum sampling rate of the
instrument.
The minimum and maximum values of samples per UI are 2
and 20 respectively. When the value of samples per UI is
out of range, the sampling rate is automatically adjusted to
achieve the specified data rate.

Data Rate Enter the data rate of the waveform. The data rate is equal
to the ratio of Sampling Rate and Samples per UI.

Sampling Rate Enter the sampling rate (in S/s) of the waveform to compile.
Samples per UI Enter the samples per UI of the waveform to compile.
Bandwidth Expansion Filter 1

Interleave Off Select Bandwidth Expansion Filter to enable this option.
This option is available only when the sampling rate is lesser
than 10 GS/s.

Interleave without Zeroing Select this to apply the bandwidth expansion filter if zeroing
is off. This option is available only when the sampling rate is
greater than or equal to 10 GS/s.

Interleave with Zeroing Select this to apply the bandwidth expansion filter if zeroing
is on. This option is available only when the sampling rate is
greater than or equal to 10 GS/s.

Compile Button Preferences
Compiles and Sends To Select this to compile and send the waveform to the specified

channel. By default, Ch1 is selected. This option is enabled
only when the SerialXpress is running in the online mode.

Compiles Only Select this to compile the waveform without sending it to the
AWG. The compiled waveform is displayed in the waveform
list.

Overwrite Waveform in SerialXpress List Select this to overwrite a waveform in the list with the
compiled waveform. When disabled, you are prompted that
a file of the same name exists.
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Table 9: Compile settings options and their description (cont.)

Selection Description
Batch Process Select this to activate batch compilation.
Show Graph after Compile Select this to display the graphs after compilation. The

compiled graph is displayed using Graph Setup dialog box.
When disabled, no plot is displayed after compilation and
the compilation time is reduced.

xxx

1 The bandwidth expansion filter is used to improve the performance of the AWG when the rise time is very high. For better use of the
bandwidth expansion filter, set the rise time to less than 100 ps.

NOTE. When Automatic option is enabled, the Sampling Rate and Samples per UI options are disabled.

Bandwidth expansion filter is used to improve the performance of the AWG when the rise time is very
high. Use a rise time of less that 100 ps for better usage of Bandwidth expansion filter.

The Compile and Sends To and Compile Only options are disabled when SerialXpress is in the offline
mode. Click Compile to compile the waveform. The compiled waveform is displayed in the waveform list.

Batch Process
Click Batch Setup from the toolbar or Compile Settings > Batch Process > Batch Setup... to set up the
batch process. This option is disabled by default.

Batch Process creates multiple waveforms with a combination of random jitter and periodic jitter with a
maximum of four different frequencies with user-defined parameter increments.

Clicking Compile starts batch compilation when Batch Process is enabled. This dialog box is displayed
upon clicking Batch Setup.

NOTE. When you navigate the batch process through Compile Settings, theWaveform Name, Compile
Button Preferences, and Show Graph after Compile options are disabled.
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s

By default, both Random Jitter and Periodic Jitter are enabled where you can set the values to be used
for batch creation. When you disable both the options and click Compile, the following error message
appears: The parameter values do not generate any waveform.

The following condition occurs when Random Jitter (Rj) and/or Periodic Jitter (Pj) values are same in both
the Batch Setup Compile dialog box and Transmitter tab:

When either Rj or Pj is disabled in the Batch Setup Compile dialog box but enabled in the Transmitter
tab, the corresponding value set in the Transmitter tab is used for compilation.

When either Rj or Pj is disabled in both Batch Setup Compile dialog box and Transmitter tab,
the value zero is used for compilation.

The following condition occurs when Random and/or Periodic Jitter have different values set in the Batch
Setup Compile dialog box and Transmitter tab:

When Batch Process is enabled in the Compile Settings dialog box, the values set in the Batch Setup
Compile dialog box are used for compilation.

When Batch Process is disabled in the Compile Settings dialog box, the value set in the Transmitter
tab is used for compilation.

NOTE. The Batch Process option is available only for a single file. It cannot be applied when multiple
pattern files or HDMI standard is selected.
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Table 10: Batch Compile Setup options and their description
Selection Description Range, Default value
Random Jitter (RMS)
Start Set the random jitter start value (in UI). 0 UI to 0.5 UI, 0 UI
End Set the random jitter end value (in UI). 0 UI to 0.5 UI, 0 UI
Increment Set the random jitter increment value

(in UI).
0 UI to 0.5 UI, 0.01 UI

Periodic Jitter (Pk-Pk)
Start Set the periodic jitter start value (in

UI).
0 UI to 50 UI, 0 UI

End Set the periodic jitter end value (in UI). 0 UI to 50 UI, 0 UI
Increment Set the periodic jitter increment value

(in UI).
0 UI to 0.5 UI, 0.01 UI

Sine 1
Frequency 1 Set the first periodic jitter frequency

(in Hz).
10 KHz to 1GHz, 10 MHz

Frequency 2 Set the second periodic jitter frequency
(in Hz).

10 KHz to 1GHz, 0 Hz

Frequency 3 Set the third periodic jitter frequency
(in Hz).

10 KHz to 1GHz, 0 Hz

Frequency 4 Set the fourth periodic jitter frequency
(in Hz).

10 KHz to 1GHz, 0 Hz

xxx

NOTE. When the same frequency value is used more than once in the Periodic Jitter, only one frequency
is used for compilation. If the value zero is set, that frequency is not used for compilation. Only Sine1
Frequency 1 is used for compilation.

Click OK to save the changes and Compile to compile the waveform. The waveform name format is
“Rj<value>Pj<value>Freq<value>”.

For Example: Rj0.2Pj0.1100000 means Rj of 0.2 UI, Pj of 0.1 UI applied on a frequency of 10 KHz.

On/Off

Click On/Off to turn on or turn off the AWG channel output. This option is enabled when
SerialXpress is running in the online mode.
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Run

Click Run to turn on or turn off the Run state of the AWG. If the application is running on an
AWG or using an offline mode of the AWG software, then the compiled waveform is directly output to the
channel and indicated by changing the Run button to green. This option is enabled when SerialXpress is
running in the online mode.
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Option Installation
Click System > Option Installation... to use the SerialXpress application to generate, transfer, and save
the waveforms. Once the trial expires, you cannot transfer or save the waveform unless you enable the
function with an option (license) key.

Click System > Option Installation.... This dialog box is displayed.

Table 11: Option installation information and their description
Selection Description
User Name Enter the user name.
Option Key String Enter the 20 digit option key string that is provided along

with the application.
Option Information The option information is displayed in the table.
xxx

Click Copy Option Info to copy the information in the table to the clipboard. Click Apply to apply
the entered values.
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Restore Default Setup
Click File > Restore Default Setup to restore the default values of all the parameters. This option is
always enabled.

Clicking Save stores the current settings into a folder in .sxs format and restores the default settings.

Open Setup
Click File > Open Setup... to browse to open a saved setup file.

All files have the file name extension .sxs. This option is always enabled.

Save Setup
Click File > Save Setup to save the setup file in the .sxs format.

Use File > Save Setup to save an existing setup file with the same name. If you are saving the setup
for the first time, the Save Setup option works exactly as the Save Setup As... option. This option is
always enabled.

Save Setup As
Click File > Save Setup As... to save the data file in .sxs format.

You must compile a setup before you can save the data. If you try to save a setup without compiling, you
are prompted to compile the setup. This option is always enabled.

Import from File
Click File > Import from File... to import a pattern file created in another application, and add these
patterns into SerialXpress. This option is always enabled.

You can import only .DTG files.
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Import from Tektronix Oscilloscope
Click File > Import from Tektronix Oscilloscope... to import a waveform file from a Tektronix
oscilloscope that is connected to your instrument into SerialXpress. This dialog box is displayed. This
option is always enabled.

A table displays a list of oscilloscopes on the network. Select an oscilloscope in the table and click
Connect to connect to it. You can connect more than one oscilloscope but can calibrate only one at a time.
Click Disconnect to disconnect from an oscilloscope.

For a connected oscilloscope, you can set the following parameters:

Table 12: Waveform import options and their description
Selection Description Default value
Data Source Select the data from which to acquire

the waveform data: Ch1 to Ch4,
Math1 to Math4, and Reference1 to
Reference4.

Ch1

Acquisition Mode Set the acquisition mode to one of
the following: Samples, Peak Detect,
Envelope, or Average.

Samples
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Table 12: Waveform import options and their description (cont.)

Selection Description Default value
Waveform Name Specify the waveform name. The

imported waveform is saved in the
specified name.

N/A

Record Length Displays the record length of the
selected oscilloscope. Change the
record length by entering a new value
in the field.

N/A

xxx

Click Acquire to import the data. The specified waveform name is used to list the waveform in the
Waveform List.

PRBS Editor
This dialog box is displayed upon clicking PRBS Editor... when Standard is set to General, and Pattern
to User-Defined in the Base Pattern tab.

This data source can generate different pseudo-random binary sequences. The available PRBS patterns
are: PRBS 7, PRBS 9, PRBS 15, and PRBS 16.

PRBS sequences are generated by a feedback shift register. The accepted value of the shift register text
boxes is 1 or 0. The number (#) following PRBS indicates the length of the generating shift register.
For instance, a shift register with 16 memory cells is required to generate a PRBS 16 sequence. The
pseudo-random sequence of a PRBS generator is determined by the number of registers and the feedback.
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Table 13: PRBS editor options and their description
Selection Description Default value
PRBS polynomial expression Enter an expression in the format

Xn1+Xn2+1 to generate the
pseudo-random sequence. The value
of Xn ranges between 1 and 31.

X7+X6+1

Shift register initial value D1– D31 Enter values in the shift registers to
create the sequence. The registers
D1 through D31 can take the values
0 and 1.

D1– D31

xxx

NOTE. SerialXpress do not support patterns of all zeroes when user-defined PRBS equation is selected.

Click Apply to effect the changes. Click Reset to Default to restore the editor to the default values.

For more details, refer to PRBS Editor Starting Values.
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Creating a Signal
Base Pattern

Setting the Base Pattern
Base data is always in the form of zeroes and ones. Base data can be of two types:

Standard patterns (such as SATA, HDMI patterns) provided as part of the SerialXpress application

User created patterns

When you select User Defined patterns, you might need to encode them. SerialXpress supports common
encoding techniques such as 8B10B, NRZ, and NRZI.

NRZI (no-return to zero inverted), where “0” indicates no change and “1” indicates the current
level. If the current waveform is high, a “1” bit value causes a transition to the low waveform level.
If the current waveform level is low, a “1” bit value causes a transition to the high waveform level.
Refer to the following example.

This is used to encode an 8-bit data to 10-bit data. This is the most common encoding mechanism
used for Serial data standards. For example SATA patterns are 8B10B encoded.

NRZ (no-return to zero), where “0” indicates low value and “1” indicates high value.

Encoding is a process by which input patterns (zeroes and ones) are modified to different patterns
(again zeroes and ones in different combinations).

To define the base pattern and source, waveform characteristics, encoding scheme, and rise/fall time
parameters, do the following:

1. Set the base pattern. This can be done in either of the following two methods:

Method 1: Selecting the Standard Base Pattern

Select the standard from the list: SATA, SAS, HDMI, Display Port, PCI-Express, Fiber Channel,
and General.

Select the pattern from a file. The available options depend on the selected standard as follows:
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NOTE. The General standard and Clock pattern are the default settings.

Table 14: Standard and Pattern options
Option Pattern selections Default
SATA The selections for SATA are: MFTP,

HFTP, SFCP4AlignR12, and others.
MFTP

SAS The selections for SAS are:
JTPAT_RD+ , JTPAT_RD–, and
others.

JTPAT_RD+

HDMI The selections for HDMI are: 480p 8
59 Gray RGB, 720p 8 60 Gray RGB,
and others.

480p 8 59 Gray RGB

DisplayPort The selections for DisplayPort are:
DP Training sequence2 960, PRBS7,
and others.

PRBS7

PCI-Express The selection for PCI-Express is:
Compliance Pat.

Compliance Pat

Fiber Channel The selection for Fiber Channel are:
CJTPAT, JTPAT, and others.

CJTPAT

General The selections for General are:
Clock, PRBS7, PRBS9, and others.

Clock
This pattern has a high frequency
clock, such as 1,0,1,0,1,0,...

xxx

Method 2: Selecting the From File Base Pattern

Browse to select a file from which to take the pattern. The file format is .txt.

SerialXpress supports:

Selecting a single pattern file from mass storage. See Creating the Base Data.

Selecting multiple pattern files from mass storage. See Creating the Base Data.

NOTE. Selecting single or multiple pattern files allows you to encode the selected data. You can skip
the encoding if not required.

When multiple pattern files are selected, the encoding type applies to all the selected pattern files.

Selecting from a list of pattern data supplied with the application.

Method 3: Selecting a User Pattern

Select any of the User Pattern formats: Binary or Hex. By default, Binary is selected.

Enter the pattern in the text box.
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You can enter up to 20 zeroes and ones. If you want to enter more than 20 digits, click Editor....
In the User Pattern Editor dialog box, you can enter up to 128 digits for Hex mode and 512
digits for Binary mode.

NOTE. Patterns with all zeroes or all ones are not supported.

2. Set the following signal characteristics:

Table 15: Signal characteristics and their description
Option Description Range, Default value
Data Rate Specify the data rate (in B/s) of the

waveform.
Range:
500 KB/s to 3. 5 GB/s (AWG7000
without interleave)
500 KB/s to 6.0 GB/s (AWG7000 with
interleave)
500 KB/s to 3300 Mbps (AWG5000)
500 KB/s to 6.0 GB/s (Offline)
Default: 1 GB/s

Amplitude Specify the amplitude (in Volts) of the
waveform.

0.25 V to 1 V, 1 V

Idle State Enter the idle state value (in samples
or secs) of the waveform.
Idle state is the state used for some
standards like SATA. During this state,
the value is neither 0 nor 1. It is a
state during which no valid data is
transferred between the transmitter
and the receiver. SerialXpress
supports Idle state waveforms with
idle value.
Idle state waveforms are individual
waveforms that can be sent to the
AWG. Use sequence mode to take
the receiver to the idle state. The
waveforms contain the DC values with
no base data during this state. You
can add number of samples and noise
as required in the idle state waveform.

52 ns to 100 μs, 53 ns

xxx
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The default data rate changes depending on the selected standard. You can change the data rate if
necessary. The following table lists the default data rate for various standards.

Table 16: Signal Standards and their default data rates
Signal Standards Data rate
SATA 3 GB/s
SAS 3 GB/s
HDMI 3.2 GB/s
DisplayPort 2.7 GB/s
PCI-Express 5 GB/s
Fiber Channel 4.25 GB/s
xxx

NOTE. When you select Idle State, the following options will be disabled:

Amplitude in the Signal group

All the parameters in the Encoding and Rise/Fall groups

SerialXpress can generate waveforms that occupy only a part of the full DAC range of the AWG. By
default, the generated waveforms occupy the whole DAC range. When SerialXpress is in the online
mode, the maximum voltage corresponds to the full DAC of the AWG on which it is running. When
SerialXpress is in the offline mode, the maximum range is assumed to be 1 Vpp (peak-to-peak).

3. Select the following encoding scheme:

Table 17: Encoding options and their description
Option Description Default
Scheme Select the encoding scheme to use:

NONE (NRZ) or NRZI.
None

8B10B Select 8B10B to encode an 8-bit data
to 10-bit data.

Enabled

Disparity

Disparity refers to starting
disparity.

Select the disparity: Positive or
Negative.

NOTE. This option is enabled
only if 8B10B is enabled.

RD+

xxx
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4. SerialXpress allows both equal and unequal rise and fall times. Set the following rise/fall time
parameters:

Table 18: Rise/Fall Time options and their description
Option Description Range, Default value
Rise/Fall Time Set the Rise/Fall time option to 10/90

or 20/80. This defines whether rise
and fall times are calculated using
10/90 or 20/80 ratio.

10/90 or 20/80, 10/90

Rise Set the rise time in s or UI. The rise
time is used to define how steep the
rising slope will be.

Range:
1/sampling rate to 1/data rate
Default: 200 ps

DCD Set the DCD in s or in UI.
When DCD is disabled, the rise and
fall times can be controlled. When
DCD is enabled, the rise and fall times
are calculated separately to achieve
the required DCD.

0 UI to 1 UI, 0 UI

Fall Set the fall time in s or UI.
When fall time is enabled, DCD will
be calculated internally. When DCD
is enabled, the fall time value will be
calculated internally.

Range:
1/sampling rate to 1/data rate
Default: 200 ps

xxx

When you change the unit for rise and fall times from UI to secs, or secs to UI, the value of rise and fall
time changes to reflect their equivalent in the new unit.

A unit interval (UI), also referred to as a bit time, is the time taken in a data stream for one bit. For
example, in a serial line with a baud rate of 2.5 GB/s, a unit interval is 1/(2.5 GB/s) = 0.4 ns/bit.

Creating the Base Data
Selecting single or multiple pattern files from mass storage

The pattern format for single or multiple pattern files is as shown:

NOTE. The file format is .txt. If a pattern file does not have the specified data in any row or data bit
as follows, then the waveform generation fails.

Row<1> D1 D2 D3 D4 D5 D6 D7 D8 D9 D10<CR><LF>

Row<2> D11 D12 D13 D14 D15 D16 D17 D18 D19 D20<CR><LF>

Row<3> D21 D22 D23 D24 D25 D26 D27 D28 D29 D30<CR><LF>
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………………………………………………………….......<CR><LF>

Row<n>…………………………………………………....<CR><LF><EOF>

where,

Row<n> refers to row number.

D30 to D1 refers to data bits with the values 1 or 0.

<CR> refers to carriage return.

<LF> refers to line feed.

<EOF> refers to end of file.

NOTE. Row number and EOF do not appear as part of the file.

<CR> and <LF> together can be considered as the end of line.

Selecting single or multiple pattern files allows you to encode the selected data. You can skip the encoding
if not required.

NOTE. When multiple pattern files are selected, the encoding type applies to all the selected pattern files.

File format for 8-bit data

<D1>,<D2>,<D3>,<D4>,<D5>,<D6>,<D7>,<D8>,<M1>,<M2><CR><LF>

<D11>,<D12>,<D13>,<D14>,<D15>,<D16>,<D17>,<D18>,<M1><M2><CR><LF>

where, <M1>,<M2> are the marker bits.

The file format for 8-bit data is as follows:
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File format for 10-bit data

<D1>,<D2>,<D3>,<D4>,<D5>,<D6>,<D7>,<D8>,<D9>,<D10><CR><LF>

<D11>,<D12>,<D13>,<D14>,<D15>,<D16>,<D17>,<D18>,<D19>,<D20><CR><LF>

The file format for 10-bit data is as follows:

Calibration for Base Pattern Signals
Calibration is available only when the SerialXpress is running on an AWG5000/AWG7000 series
instrument.

For Base Pattern waveforms, connect the AWG and oscilloscope as follows:
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The rear panel connections of the AWG and oscilloscope are as shown:

Creating Calibration Data
1. Select Calibration from the toolbar.

2. From the list of instruments, highlight an oscilloscope and click Connect.

3. Set the Calibration parameters. The calibration parameters are: Sampling rate, Data rate, Interleave,
and Zeroing. You can leave these parameters with their default values or set them as you like. For more
details, refer to Calibration.

4. Click Calibrate. A status message displays the status of processing.

NOTE. The difference between the generated waveform and the reference waveform is calculated for
each iteration.

The files (.sxc) created contains calibration data.
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Transmitter

Setting Jitter Parameters
Click Transmitter tab to add periodic and random jitter to the waveform that you want to create. To
add jitter, do the following:

1. To introduce one or more sine waves as periodic jitter, enable one or more check boxes. Set the
Magnitude (UI), Frequency (Hz), and Phase (°) for each.

Table 19: Setting periodic jitter parameters
Option Description Range, Default
Magnitude Set the magnitude of the sine wave

(jitter) (in UI) to introduce.
0 UI to 50 UI, 0 UI

Frequency Set the frequency of the sine wave
(jitter) (in Hz) to introduce.

10 KHz to Data rate/2, 10 MHz

Phase Set the phase of the sine wave (jitter)
(in degrees) to introduce.

0 ° to 360 °, 0 °

xxx

For examples on periodic jitter, refer to Periodic Jitter Sample Test Results.

2. To add one or more random jitters, enable one or more check boxes. Set the Magnitude (UI),
Frequency-Low (Hz), and Frequency-High (Hz) for each.

Table 20: Setting random jitter parameters
Option Description Range, Default
Magnitude Set the magnitude of the sine wave

(jitter) (in UI) to introduce.
0 UI to 0.5 UI, 0 UI

Frequency-Low Set the low frequency of the sine wave
(jitter) (in Hz) to introduce.

1 Hz to 100 KHz, 100 KHz

Frequency-High Set the high frequency of the sine
wave (jitter) (in degree) to introduce.

100001 Hz to Data rate/2, Data rate/2

xxx

The random jitter generated through a random sequence is independent for each compilation.

3. To specify SSC parameters, select SSC and set the following parameters:

Table 21: Setting SSC parameters
Option Description Range, Default value
Shape Select the shape of the SSC profile

to use. The available selections are:
Sine and Triangle.

Triangle

Spread Select the SSC spread to use. The
available selections are: Up, Down,
Center, and Unequal.

Down
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Table 21: Setting SSC parameters (cont.)

Option Description Range, Default value
Unequal Spread Enter the unequal spread. 0% to 100%, except 50 indicates

unequal spread.
0 is equivalent to Down spread.
50 is equivalent to Center (equal)
spread.
100 is equivalent to Up spread.
Default: 0%

df/dt Enter the df/dt of the waveform. This
defines the sudden deviation (spikes)
of the SSC profile from the pre-defined
pattern. The number of spikes per
cycle is 10.

0 ppm/µs to 2000 ppm/µs, 0 ppm/µs

Frequency
Deviation (Hz) Enter the frequency deviation. This

defines the maximum deviation of the
data rate from mean data.

0 ppm to 6000 ppm, 4000 ppm

Modulation Enter the frequency modulation.
This defines the frequency of the
modulating SSC profile.

0 KHz to 120 KHz, 33 KHz

Noise Enter the additive noise to be
introduced.

0 ppm to 100 ppm, 0 ppm

xxx

4. SerialXpress supports adding noise and peak controlled pre-emphasis. Select and enter the following:

Table 22: Noise and Pre-Emphasis options and their description
Option Description Range, Default
Noise Enter the amplitude of the noise (in

volts) to generate.
0 Volt (RMS) to 0.5 Volt (RMS), 0 Volt
(RMS)

Pre/De-emphasis Enter the amplitude (in dB or volts) of
the pre-emphasis to be introduced in
the waveform.

0 dB to 10 dB, 0 dB

Add Noise At Select where the random noise will
be added to the waveform. It can be
added to simulate the near end or far
end.

Near end and Far end, Near end

xxx

Channel/Cable

46 SerialXpress® User Manual



Creating a Signal Setting ISI and S-Parameter Filter Parameters

Setting ISI and S-Parameter Filter Parameters
Click Channel/Cable tab to specify inter-symbol interference (ISI) or S-Parameter Filter parameters
for the waveform.

1. To specify the ISI, select the ISI option.

2. To specify the S-Parameter filter, select the S-Parameter Filter option.

3. Set the following channel/cable parameters:

Table 23: Channel/Cable options and their description
Option Description Range, Default
ISI Select this option and specify the

inter-symbol interference (in UI or
seconds).

0 UI to 1 UI, 0 UI

S-Parameter Filter
Read from File Browse and select the file from which

to read the filter.
The files supported are .s1p, .s2p,
and .s4p.

.s4p

Inverse Filter Select this to apply an inverse filter.
This is used to neutralize the effect of
the cable and produce an undistorted
waveform.
To get an undistorted waveform,
select the corresponding S-Parameter
file of the cable in use using the Read
from File. Inverse Filter is applied to
the generated waveform and passed
through the cable to the DUT. An
undistorted Eye DPO waveform is
produced at the DUT.

Disabled

ISI Scaling Enter the ISI scaling. 0 to 10, 1
xxx

The S-parameter (Touchstone) file can contain data for 1-port, 2-port, or 4-port devices. Once a file is
selected, the application reads its contents and generates the appropriate dialog box for you to select the
particular S-parameter in the file to use.

One-port: Files with one port of data contain only one S-parameter file (.s1p) so they do not require
any further input.

Two-port: Files with data for two ports contain four S-parameters as a 2x2 matrix. These are
Touchstone 2-port files (.s2p). When the application recognizes such an S-parameter file, a dialog box
is created for you to select the S-parameter representing channel transmission. By default, SerialXpress
assumes the location of the channel transmission data in the file to be S21.
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Four-Port: Files with data for four ports may contain single-ended or differential data. These are
Touchstone 4-port files (.s4p). By default, SerialXpress assumes the file to be Differential data type.

If the data is single-ended, you must map the port numbers as used in the file to physical locations in
your link. A default mapping is assumed. The application will use this mapping to compute the Sdd21
parameter (for transmission of a differential signal) from the appropriate four S-parameters measured
using single-ended data.
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You can select the port for both transmitter and receiver from the drop-down list. Each drop-down
list has ports from 1 to 4. The default port number is as follows:

Table 24:
Type Default port
Tx+ 1
Tx- 3
Rx+ 2
Rx- 4
xxx

If the data is differential, you must select the data layout in the file. By default, SerialXpress assumes the
file to use DC12 data location format. The application always uses the Sdd21 parameter for computing the
transmitted waveform no matter which mapping is selected.

SerialXpress® User Manual 49



Creating a Signal Setting ISI and S-Parameter Filter Parameters

50 SerialXpress® User Manual



Instrument Control Controlling an Instrument

Instrument Control

Controlling an Instrument
SerialXpress can be used to control a connected instrument (for example a Tektronix oscilloscope) in
many ways. You can:

Install SerialXpress on an AWG5000/AWG7000 series instrument. SerialXpress can directly send and
receive data from the AWG.

Install an offline version of SerialXpress on a PC with an offline version of the AWG software. In this
case, SerialXpress can detect the presence of the AWG and send data to it. This data can be opened and
viewed in the AWG.

Follow these steps to find other instruments connected to the instrument on which SerialXpress is running:

1. Click Find Instruments. The following dialog box opens.

The table lists the instruments found along with the name of the instrument, model, status (connected or
not), and the connection type (Ethernet or GPIB).
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2. Select an instrument from the table. Use the following buttons to:

Table 25: Find instruments options and their description
Button Description
Connect Allows you to connect to the selected instrument in the

table. Enabled by default if an instrument is highlighted in
the table; disabled if no instrument is highlighted.

Disconnect Allows you to disconnect the connected instrument.
Enabled only when an instrument is connected.

Refresh Refreshes the list of instruments.
Import... Opens the Import from Tektronix Oscilloscope... dialog

box.
xxx

3. Click Connect to connect to the selected instrument.

Controlling an AWG
Waveform transfer to and control of the AWG5000/AWG7000 series instruments can be performed
directly from SerialXpress. You can run the SerialXpress on an AWG5000/AWG7000 series instruments
and control it.

You can control the following AWG parameters:

Channel waveform

Amplitude

Sampling rate

Interleave (AWG7102 Option 06 only)

Interleave Zeroing (AWG7102 Option 06 only)

SerialXpress supports the following operations:

Transferring a waveform data to AWG5000/AWG7000 as real format waveform.

During this operation, the marker data is also transferred.

Loading a waveform to a channel.

Changing the run state.

Perform the following steps to control and transfer a waveform to an AWG:

1. SelectWindow > Instrument Control.

2. From the AWG tab, you can modify the values of the following AWG parameters:
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Table 26: AWG parameters and their description
Selection Description Default value
Sampling Rate Displays the sampling rate of the

AWG.
The default is as set in the AWG.

Interleave Sets the interleave option to On or Off. Off
Zeroing Enabled only when Interleave is set

to On.
Disabled

Ch 1 Select this to receive the output from
channel 1.

This depends on the channel present
on the AWG.

Ch 2 Select this to receive the output from
channel 2.

This depends on the channel present
on the AWG.

Amplitude (Vpp) Displays the amplitude of the selected
channel. Change the amplitude in this
field to change the amplitude on the
channel.

The default is as set in the AWG.

Waveform Displays the selected waveform
name. You can drag and drop the
waveform from the Waveform List.
When you drag and drop a waveform,
the sampling rate is automatically set.

N/A

xxx

The following button is available:

Table 27: AWG options
Button Description
Advanced Opens a dialog box where you can set the advanced AWG

control options.
xxx
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3. When you click Advanced, the following options are available for each channel:

Table 28: Advanced AWG parameters
Selection Description
DAC Resolution
8 bits Sets the DAC resolution to 8 bits.
10 bits Sets the DAC resolution to 10 bits. When the DAC resolution

is set to 10 bits, the marker options are not available.
Markers (M1 and M2)
High (V) Enter the high value for the markers.
Low (V) Enter the low value for the markers.
Delay (s) Enter the maker delay.
xxx

NOTE. When connected to an AWG5000 series instruments, the DAC resolution is fixed to 14 bits and
cannot be changed.
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Connecting to and Controlling an Oscilloscope
You can connect to and control a Tektronix oscilloscope using SerialXpress. Perform the following steps:

1. SelectWindow > Instrument Control.

2. A table lists the connected oscilloscopes. From the Oscilloscope tab, you can modify the values of
the following oscilloscope parameters:

NOTE. Ensure that the Sampling mode on the oscilloscope is set to Real Time. If the Sampling mode is
set to Interpolation (either automatically or manually), the parameter values in SerialXpress Instrument
control and the oscilloscope may not match.

Table 29: Oscilloscope parameters
Selection Description
Vertical Settings
Channel Displays the channel to which to output the waveform. To

change this setting, select another channel.
Scale (V) Displays the vertical scale set in the oscilloscope for the

selected channel. Change the value in this field to change
the vertical scale on the connected instrument.

Horizontal Settings
Scale (s) Displays the horizontal scale set in the oscilloscope.

Change the value in this field to change the horizontal scale
on the connected instrument.

Record Length Displays the record length set in the oscilloscope. Change
the value in this field to change the record length on the
connected instrument.

Sampling Rate (S/s) Displays the sampling rate set in the oscilloscope. Change
the value in this field to change the sampling rate on the
connected instrument.

Acquisition
Run Starts the acquisition of data on the oscilloscope.
Stop Stops the acquisition of data on the oscilloscope.
Single Sets the oscilloscope to acquire one full record length and

then stops.
xxx
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The following buttons are available in this tab:

Table 30: Oscilloscope options
Button Description
AutoSet Performs autoset on the oscilloscope.
Refresh Settings Refreshes the display with the current instrument settings.
Refresh List Refreshes the connection status of the instruments.
Find Instruments Finds instruments on the network.
xxx
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Graphing

Zooming Graphs
You can zoom in or zoom out on a graph. ClickMaximize to display the graph in a large window. You can
zoom in on a plot by selecting an area of interest. SerialXpress supports the following graphs:

Rise/Fall

Simulated Data Signal

Random Jitter

Periodic Jitter

Total Jitter

Normal Eye

Eye DPO

TIE

You cannot save the graphs. You can only save the graphs by doing a screen capture. You must regenerate
a graph using Compile every time you change parameter values. The existing graphs are not automatically
updated.

For more details, refer to Graph Setup.
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Rise/Fall
The rise/fall graph shows the plot of Time (Samples) (X-axis) and Amplitude (Volts) (Y-axis).
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Simulated Data Signal
The simulated data waveform graph shows the plot of Time (Samples) (X-axis) and Amplitude (Volts)
(Y-axis).
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Random Jitter
The random jitter graph shows the plot of Tie Error (ps) (X-axis) and Frequency of Occurrence (Y-axis).

60 SerialXpress® User Manual



Graphing Periodic Jitter

Periodic Jitter
The periodic jitter graph shows the plot of Tie Error (ps) (X-axis) and Frequency of Occurrence (Y-axis).
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Graphing Total Jitter

Total Jitter
The total jitter graph shows the plot of Tie Error (ps) (X-axis) and Frequency of Occurrence (Y-axis).
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Graphing Normal Eye

Normal Eye
The normal eye graph shows the plot of Time (UI) (X-axis) and Amplitude (Volts) (Y-axis).
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Graphing Eye DPO

Eye DPO
The eye DPO graph shows the plot of Time (UI) (X-axis) and Amplitude (Volts) (Y-axis).

The following table shows the summary of the various jitter parameters used to create the waveform:

In the Eye DPO plot, all the jitter parameters that are set in the application are shown in a table.

The total jitter is calculated using the formula Tj = ( 14 * Rj ) + Dj where,

Tj is the Total Jitter at a specified Bit Error Rate (TJ@BER). This extrapolated value predicts a
peak-to-peak jitter that will only be exceeded with a probability equal to the BER (TJ (1E-12)).

Rj is the RMS value of total Random Jitter. , where Rj1 and Rj2 are RMS values
of two independent, band limited, zero mean, and Gaussian distribution jitters.
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Dj is the Deterministic Jitter, which is the sum of Periodic Jitter (Pj), Inter Symbol Interference (ISI), and
Duty Cycle Distortion (DCD).

TIE
The TIE graph shows the plot of Frequency (Hz) (X-axis) and Jitter (Secs) (Y-axis). This plot shows
the raw Fast Fourier Transform (FFT) of the TIE.
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Reference

Error Messages
The following table lists the error codes for the application.

Table 31: Error Messages for SerialXpress
Error message Description Solution
Not ready. SerialXpress application is not ready. Start SerialXpress.
SerialXpress instance is already
running.

Second instance of SerialXpress is
started.

Check task manager if the
SerialXpress application is already
running. If the application is
running, stop that process and start
SerialXpress again.

Trial period has expired.
You cannot transfer and save the
waveform.

The total number of trials of 10 is
exceeded.

Enable the function (to transfer or
save the waveform) with an option
(license) key.

Invalid file name. File name is not according to
SerialXpress requirements.

Apply Microsoft Windows file naming
conventions.

File does not exist. The specified file name does not exist. Ensure that the file path and name are
correct.

Directory does not exist. The specified directory is incorrect. Browse the correct directory instead
of entering the path.

Invalid Entry - All Ones are not
allowed.

Patterns with all ones are not
supported.

Enter patterns with the combination of
zeroes and ones.

Invalid Entry - All Zeros are not
allowed.

Patterns with all zeroes are not
supported.

Enter patterns with the combination of
zeroes and ones.

Unable to compile waveform. The application fails to create the
waveform.

Ensure that the base data size does
not exceed 2.5 MB.

DTG file import failed. Either the file is corrupt or DTG file
format is incorrect.

Ensure that the DTG file format is
correct and that the file is not corrupt.

Waveform name cannot be empty. The waveform name is not specified. Specify a waveform name that does
not exceed 32 characters.

No selected waveform to save. No waveform has been selected to
save.

Select a waveform to save.

Waveform name specified already
exists.

The same waveform name is
specified.

Perform one of the following:

Ensure that the waveform name
is different.

Ensure that the Overwrite
option is enabled in the Compile
Settings dialog box.

Batch setup settings error. The Start value of either Random
Jitter or Periodic jitter is greater than
the End value.

Ensure that the Start value is less
than the End value in the Batch
Compile Setup dialog box.
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Table 31: Error Messages for SerialXpress (cont.)

Error message Description Solution
Both random jitter and periodic jitter
are disabled. Batch compile will
not generate any waveforms in this
condition.

The Batch Compile Setup dialog box
has both Random and Periodic Jitter
disabled.

Ensure that one or both Random and
Periodic Jitters are enabled.

Error on parsing PRBS polynomial. The PRBS polynomial syntax is
incorrect.

Enter the correct PRBS polynomial.

Invalid file format. File format is incorrect. Apply valid file format.
AWG is not available. The Advanced option in Instrument

Control tab has been clicked without
starting the AWG application.

Ensure that AWG application is started
before starting SerialXpress.

Unauthorized access permission. Permission not available to read a file. Ensure that the file has read
permission.

xxx

Shortcut Keys
Table 32: Shortcut keys
Menu/Menu item Shortcut key
File Alt+F
File > Open Setup... Ctrl+O
File > Save Setup Ctrl+S
File > Restore Default Setup Ctrl+N
View Alt+V
Configure Alt+C
Waveform Alt+W
System Alt+S
Window Alt+I
Help Alt+H
xxx
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PRBS Editor Starting Values
The following table gives the initial shift register values and the PRBS polynomial expression:

Table 33: Initial shift values and PRBS polynomial expressions
PRBS Shift register initial value PRBS polynomial expression
PRBS 7 1 1 1 1 1 1 X7+X6+1=0
PRBS 9 1 1 1 1 1 1 1 1 1 X9+X5+1=0
PRBS 15 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 X15 +x14+1=0
PRBS 16 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 X16+X14+X13+X11+1=0
xxx

AWG Specifications
You can refer to the specifications in the Technical Reference for AWG7000 Series Arbitrary Waveform
Generators Specifications and Performance Verifications, Tektronix part number 071-1853-XX.

You can view the document by selecting Start > All Programs > Tektronix > AWG > Documentation >
Technical Reference Manual.

Interleave
The AWG7102 Option 06 supports the interleaving mode. Interleaving is a mode where the sampling
rate ranges from 10 GS/s to 20 GS/s. The following table shows the amplitude and sampling rates for the
interleaving and non-interleaving modes.

Table 34: Amplitude and sampling rates in non-Interleave and interleave modes
Non-Interleaving Interleaving
Amplitude (min, max) Sampling rate (min, max) Amplitude (min, max) Sampling rate (min, max)
500 mVpp, 1 Vpp 10 MS/s, 10 GS/s 500 mVpp, 1 Vpp 10 GS/s, 20 GS/s
xxx

In the Interleaving mode, the output is available in a separate interleave connector as shown in the figure.
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As an example, in the non-interleave mode let the sampling rate be 20 GS/s and the original amplitude
samples be 0.1, 0.2 , 0.3, 0.4, 0.5 , 0.1, 0.2. This can be represented graphically as shown here.

In the interleave mode, alternate samples are output from each channel. That is, the samples are distributed
between the two channels as shown:

Ch1 Ch2
0.1 0.2
0.3 0.4
0.5 0.1
0.2 0
xxx
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This can be represented graphically as shown.

Zeroing
When Interleave is on, you can turn Zeroing on or off to enhance the available bandwidth. This function
is available only when Interleave is available. If you compose waveform data that is divided into two
channels, the zeroing function allows you to select whether you want to handle each waveform as RZ
(Return to Zero) or NRZ (Non Return to Zero).

If you turn the zeroing function on, the bandwidth increases. However, spurious characteristics will worsen
(increase in the frequency spectra that should not be output) and the amplitude range will be halved.
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Parameter Definitions
Definitions of the jitter and time related parameters are given in the following table:

Table 35: Jitter/Time parameters and their description
Parameters Description
Jitter
RJ Random Jitter is jitter that does not exhibit deterministic

behavior and is not bounded. It can be described by a
Gaussian probability distribution. It is characterized by
standard deviation value (RMS).

PJ Periodic Jitter is the portion of the deterministic jitter that
is periodic, but for which the period is not correlated with
any data in the waveform. It is measured by peak-to-peak
variation and frequency.

DCD Duty Cycle Distortion is the portion of the deterministic jitter
directly correlated with waveform polarity (the difference in
the positive edges and negative edges).

Noise This is a type of additive white noise that modifies the
vertical amplitude of the serial data and contributes to the
jitter.

Time
Rise Time Elapsed time between the Low reference level crossing

and the High reference level crossing on the rising edge
of the waveform. It is measured in time units between the
10% and 90% levels or between the 20% and 80% levels.

Fall Time Elapsed time between the High reference level crossing
and the Low reference level crossing on the falling edge
of the waveform. It is measured in time units between the
10% and 90% levels or between the 20% and 80% levels.

xxx
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About Calibration
SerialXpress creates pre-distorted waveforms with precise amount of distortion. The types of distortion
can include random jitter, ISI, and others. The AWG generates these waveforms from the SerialXpress and
transmits them to the DUT through a cable. These generated waveforms are measured on the oscilloscope.
If the resulting waveform is not as expected, it could be due to distortion caused by either inherent jitter
within the AWG or the characteristics of the transmitting cable. Calibration minimizes the errors in
random jitter, rise time, and fall time.

Calibration is performed on a specific AWG, oscilloscope, and associated cable and fixtures with a defined
sampling rate and data rate. Changes in any of these requires recalibration.

Error is the deviation between the expected result and the actual result.

The calibration data is saved as .sxc file.

.sxc is a custom format binary file which includes correction information on Rj, Pj, Rise time, and
Fall time. For waveforms having the same sampling and data rate, you can reuse the same .sxc file
instead of calibrating again.

About Spread Spectrum Clocking (SSC)
Spread Spectrum Clocking (SSC) is the technique of modulating the clock frequency to minimize electro
magnetic induction (EMI) effects. SSC is generated with a profiles having a frequency and frequency
deviation. The frequency deviation is specified in ppm. The available SSC profiles are sinusoidal and
triangle.

NOTE. To generate integer cycles of the SSC profile, the software may alter the frequency of the SSC to
meet the memory requirements of the instrument.
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About Inter Symbol Interference (ISI)/ISI Scaling
Inter Symbol Interference (ISI) is generated due to the limited bandwidth of the channel. The following
are the two ways to generate ISI:

Method 1: Using digital filter to simulate the effect of ISI by directly entering the ISI value in the
Channel/Cable tab

When ISI is 0, the waveform is undistorted.

When ISI is greater than 0, the waveform is distorted. As the value of ISI increases, the distortion increases.

Method 2: Using S-Parameter filter and ISI scaling

The S-Parameter files contains the values of the specific devices used to connect the DUT. When you
select an S-Parameter file, the corresponding values of the device are applied to the waveform causing
distortion. If you use the cable of the corresponding S-Parameter file instead of the S-Parameter file, the
same output is obtained at the DUT.

NOTE. ISI scaling is enabled only when you select S-Parameter Filter.

When ISI scaling is 0, the effect of ISI is not seen and the waveform is undistorted.

When ISI scaling is in the range 0–1, the effect of ISI gradually increases. At 1, the effect of ISI is
completely introduced thereby causing a distorted waveform.

When ISI scaling is in the range 1–10, the effect of ISI will further increase.

You can see the effect of ISI in the Eye DPO plot and the Data Dependent Jitter (DDJ) can be measured on
the oscilloscope. As the data rate and the sampling rate increase, the effect of ISI increases.
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White Noise
SerialXpress supports white Gaussian distribution. Since the noise is generated in the digital domain, the
Gaussian distribution is spectrally flat and is half the sampling frequency. The amplitude of this noise can
be controlled. The noise generated is independent for each compilation.

Limitation of pattern length on randomness
The noise is created as part of the waveform data. Due to AWG memory limitations, the waveform
data has finite length. This limits randomness of the noise. The larger the waveform length, the greater
is the randomness of the noise. The AWG supports waveforms up to 64 M samples and hence the noise
is random upto this limit. For waveforms greater than 64 M samples, the noise pattern repeats. This
limitation of the AWG pattern length applies to random jitter.

Impact of noise on a differential waveform
When noise is added to a differential waveform, its amplitude appears doubled. This is because the noise is
generated in the application and appears as a waveform output for AWG.

Periodic Jitter — Sample Test Results
The maximum value of periodic jitter that can be set in the Transmitter tab for various combinations of
data rate and frequency is as follows:

Table 36: Periodic jtter maximum values
Data
Rate Frequency of Periodic Jitter

100
KHz

500
KHz

1 MHz 10 MHz 20 MHz 40 MHz 80 MHz 100
MHz

500
MHz

Periodic Jitter (Pk-Pk)
0.5
GB/s

50 UI 30 UI 18 UI 10 UI 6 UI 2 UI 1 UI 0.25 UI -

1 GB/s 50 UI 35 UI 25 UI 15 UI 10 UI 6 UI 2 UI 1 UI -
2 GB/s 50 UI 40 UI 35 UI 20 UI 15 UI 10 UI 4 UI 1 UI 1 UI
3 GB/s 50 UI 50 UI 40 UI 30 UI 20 UI 12 UI 6 UI 2 UI 1 UI
4 GB/s 50 UI 50 UI 50 UI 40 UI 30 UI 15 UI 8 UI 2 UI 1 UI
5 GB/s 50 UI 50 UI 50 UI 45 UI 35 UI 16 UI 8 UI 4 UI 1 UI
6 GB/s 50 UI 50 UI 50 UI 50 UI 40 UI 20 UI 12 UI 4 UI 1 UI
xxx
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Main Menu Default States

Table 37: Default states and selection
Item Options Default state
Menu bar

Restore Default Setup Always enabled
Open Setup… Always enabled
Save Setup Always enabled
Save Setup As… Always enabled
Import from File… Always enabled
Import from Tektronix Oscilloscope… Always enabled
Save Data As… Always enabled

File

Exit Always enabled
Standard Toolbar Always enabledView
Status Bar Always enabled

Configure Find Instruments… Always enabled
Compile Always enabled except when the

compilation is in progress.
Compile Settings... Always enabled

Waveform

Graph Setup... Always enabled
Run Enabled when SerialXpress is running

in the online mode.
Stop Enabled when SerialXpress is running

in the online mode.
All Outputs On/Off Enabled when SerialXpress is running

in the online mode.
Calibration... Enabled when SerialXpress is running

in the online mode.

System

Option Installation Always enabled
Waveform List Always enabled
Graph Always enabled
Instrument Control Always enabled
Overview Always enabled

Window

Close All Always enabled
Help Topics... Always enabled
Technical Support... Always enabled

Help

About SerialXpress... Always enabled
Toolbar
Calibration - Enabled when SerialXpress is running

in the online mode.
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Table 37: Default states and selection (cont.)

Item Options Default state
Overview - Always enabled
Find instruments - Always enabled
Graph Setup - Always enabled
Compile - Always enabled except when

compilation is in progress.
Compile Settings - Always enabled
Batch Setup - Always enabled
On/Off - Enabled when SerialXpress is running

in the online mode.
Run - Enabled when SerialXpress is running

in the online mode.
xxx
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Default Values
Table 38: Default values and selection
Item Option Range/selection Default value/selection
Base Pattern tab

Standard SATA, SAS, HDMI, Display
Port, PCI-Express, Fiber
Channel, and General

General

Pattern Selections are different for
different patterns

Clock

From File - Disabled

Base Pattern

User Pattern - Disabled
Data Rate 500 KB/s to 3.5 GB/s

(AWG7000 without
interleave)
500 KB/s to 6.0 GB/s
(AWG7000 with interleave)
500 KB/s to 3300Mbps
(AWG5000)
500 KB/s to 6.0 GB/s
(Offline)

1 GB/s

Amplitude 0.25 V to 1 V 1 V

Signal

Idle State 52 ns to 100 μs 53 ns
Scheme NONE (NRZ) or NRZI NONE (NRZ)
8B10B Enabled or Disabled Enabled

Encoding

Disparity RD+ or RD- RD+
Rise/Fall Time 10/90 or 20/80 10/90
DCD 0 UI to 1 UI 0 UI
Rise 1/sampling rate to 1/data

rate
200 ps

Rise/Fall

Fall 1/sampling rate to 1/data
rate

200 ps

Transmitter tab
Magnitude 0 UI to 50 UI 0 UI
Frequency 10 KHz to Data rate/2 10 MHz

Periodic Jitter

Phase 0 ° to 360 ° 0 °
Magnitude 0 UI to 0.5 UI 0 UI
Frequeny-Low (Hz) 1 Hz to 100 KHz 100 KHz

Random Jitter

Frequency-High (Hz) 100001 Hz to Data rate/2 Date rate/2
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Table 38: Default values and selection (cont.)

Item Option Range/selection Default value/selection
Shape Sine, Triange Triangle
Spread Up, Down, Center, Unequal Down
Unequal Spread 0% to 100% 0%
df/dt 0 ppm/μ to 2000 ppm/μs 0 ppm/μs
Frequency Deviation 0 ppm to 6000 ppm 4000 ppm
Frequency Modulation 0 KHz to 120 KHz 33 KHz

SSC

Noise 0 ppm to 100 ppm 0 ppm
Noise - 0 Volt (RMS) to 0.5 Volt

(RMS)
0 Volt (RMS)

Pre-emphasis - 0 dB to 10 dB 0 dB
Add Noise At - Near end or far end Near end
Channel/Cable tab
ISI - 0 UI to 1 UI 0 UI

Read from File - N/A
Inverse Filter Enabled or Disabled Disabled

S-Parameter Filter

ISI Scaling 0 to 10 1
xxx
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Symbols and Numbers
8B10B, 40

A
Amplitude, 39
Application

basic operations, 9
exiting, 11
installation, 4
ordering, 3
overview, 10
starting, 11
system requirements, 3

Arbitrary waveform generator
(AWG)
control, 52
specifications, 69

Automatic, 27

B
Bandwidth expansion filter, 27
Base data

calibration, 43
creating calibration data, 44
creation, 41
settings, 37
setup for signal generation, 4

Base pattern tab, 37

C
Calibration, 20

setup for RT-Eye Serial
Compliance and
Analysis, 5

Channel/Cable tab
settings, 47

Conventions, 1

D
Data rate, 39

default values for various
standards, 40

DCD, 41
Default values, 78
Delete

waveform, 19
df/dt, 46
Differential, 49
Directories, 12
Disparity, 40
Duty cycle distortion, 72

E
Encoding scheme, 37
Error messages, 67
Eye DPO, 64

F
Fall time, 72
Far end, 46
Feedback, 2
File format

10-bit data, 43
8-bit data, 42

File name extensions, 12
Free trial, 1
Frequency

Deviation, 46
Modulation, 46

G
Graphs

types, 57
zooming, 57

I
Idle state, 39

waveforms, 39

Import from Tektronix
oscilloscope, 19

Importing data from a file, 33
Instruments

control, 51
Inter symbol interference (ISI), 74
Interleave, 21
Inverse filter, 47
ISI scaling, 74

J
Jitter parameters

settings, 45
Jitter summary, 64

K
Key features, 10

M
Main menu default states, 76
Menu bar, 14

Configure, 15
File, 14
Help, 17
System, 16
View, 15
Waveform, 15
Window, 16

N
Near end, 46
Noise, 46

white noise, 72
Normal eye, 63

O
Open setup, 33
Option

software, 3
Option installation

license key, 32
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Oscilloscope
connect and control, 55

P
Parameters

definition, 72
Periodic jitter, 45
PRBS editor, 35

starting values, 69
Pre/De-emphasis, 46

R
Random jitter, 45
Read from file, 47
Related documentation, 1
Rename

waveform, 19
Restore default setup, 33
Rise time, 72
Rise/Fall, 58

S
S-Parameter, 47

four-port, 48
one-port, 47
two-port, 47

Save data as, 19
Save setup, 33
Save setup as, 33
Send to AWG, 19
Shape, 45
Shortcut keys, 68
Show graph, 19
Signal

Patterns, 37
Standards, 37

Simulated data signal, 59
Sine 1, 30
Single-ended, 48
Spread, 45
Spread spectrum clocking

(SSC), 73
Status bar, 18

offline mode, 18
online mode, 18

T
TIE, 65

Toolbar, 17
Batch setup, 28
Calibration, 20
Compile, 26
Compile settings, 26
Find Instruments, 24
Graph setup, 24
On/Off, 30
Overview, 23
Run, 31

Total jitter, 62
Transmitter tab, 45

U
Unequal spread, 46
User pattern, 38

W
Waveform list, 18
White noise, 75

Z
Zeroing, 71
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